TaxJar Reporting Slowness
Incident Report for TaxJar
Resolved
This incident is now resolved.
Posted 8 months ago. Jan 13, 2019 - 00:02 CST
Monitoring
Our engineering team has been able to restore service to TaxJar at this time. We will be monitoring the system and report back when all is resolved.
Posted 8 months ago. Jan 12, 2019 - 22:17 CST
Investigating
We are currently investigating slowness reports from TaxJar Reporting app, app.taxjar.com.
Posted 8 months ago. Jan 12, 2019 - 21:51 CST
This incident affected: TaxJar Reporting.