TaxJar Reporting - Dashboard Performance Issues

Incident Report for TaxJar

Resolved

This incident has been resolved.
Posted Jul 15, 2022 - 16:12 EDT

Monitoring

We have identified an issue with TaxJar Reporting UI performance and are implementing a fix.
Posted Jul 15, 2022 - 16:03 EDT
This incident affected: TaxJar Reporting.