TaxJar Degraded Performance
Incident Report for TaxJar
Resolved
This incident has been resolved.
Posted 10 days ago. Dec 03, 2018 - 17:16 CST
Monitoring
A fix has been implemented; performance has returned to normal. We're monitoring the app closely.
Posted 10 days ago. Dec 03, 2018 - 17:07 CST
Identified
We've identified the source of the performance issues and are working towards a fix.
Posted 10 days ago. Dec 03, 2018 - 17:03 CST
Investigating
We're investigating reports of slow responses and timeouts from the main TaxJar application.
Posted 10 days ago. Dec 03, 2018 - 16:59 CST
This incident affected: TaxJar Reporting.