We are investigating reports of users receiving an unusually high volume of emails from the TaxJar Reporting Application

Incident Report for TaxJar

Resolved

This incident has been resolved.
Posted Nov 20, 2024 - 11:59 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2024 - 11:20 EST

Investigating

We are currently investigating this issue.
Posted Nov 20, 2024 - 09:33 EST
This incident affected: TaxJar Reporting.