TaxJar Reporting Issues
Incident Report for TaxJar
Resolved
This incident has been resolved.
Posted Aug 31, 2022 - 16:27 EDT
Investigating
We are actively investigating an issue regarding account updates.
Posted Aug 31, 2022 - 15:26 EDT
This incident affected: TaxJar Reporting.