TaxJar Reporting - Performance Issue
Incident Report for TaxJar
Resolved
This incident has been resolved.
Posted Aug 15, 2022 - 21:47 EDT
Investigating
We are currently investigating this issue.
Posted Aug 15, 2022 - 21:12 EDT
This incident affected: TaxJar API (Tax Calculations API, Transaction Push API) and TaxJar Reporting.