New account creation
Incident Report for TaxJar
Resolved
Stripe has resolved their degraded service and all of TaxJar billing operations are available again.
Posted 2 months ago. Jul 10, 2019 - 20:06 CDT
Identified
We are currently monitoring an issue with a vendor having a partial outage around our account creation process. Users might have trouble creating new accounts in TaxJar Reporting at this time.

Other services are all operational.
Posted 2 months ago. Jul 10, 2019 - 16:44 CDT
This incident affected: TaxJar Reporting.