Reporting and API performance degredation
Incident Report for TaxJar
Resolved
Performance issues have been resolved by our service providers.
Posted about 3 years ago. Sep 20, 2015 - 13:18 CDT
Identified
Some of our hosting providers are experiencing issues at this time. We are monitoring and working to have things back up asap.
Posted about 3 years ago. Sep 20, 2015 - 11:48 CDT