TaxJar Reporting - Dashboard Performance Issue
Incident Report for TaxJar
Resolved
This incident has been resolved.
Posted Jul 23, 2022 - 13:13 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2022 - 12:36 EDT
Investigating
We are currently investigating this issue.
Posted Jul 23, 2022 - 12:34 EDT
This incident affected: TaxJar Reporting.