TaxJar Reporting Slowness
Incident Report for TaxJar
Resolved
A faulty database instance has been identified and replaced. After monitoring the fix we believe this issue to be resolved.
Posted 8 months ago. Jan 13, 2019 - 22:02 CST
Investigating
We are currently investigating this issue.
Posted 8 months ago. Jan 13, 2019 - 21:20 CST
This incident affected: TaxJar Reporting and TaxJar SmartCalcs (Transaction Push API).