Verification is currently underway for the maintenance items.
Posted Aug 31, 2025 - 08:37 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 31, 2025 - 07:00 EDT
Scheduled
We will be performing database upgrades during this timeframe. During these upgrades there will be momentary interruptions of service related to transaction queries and access to reports in the TaxJar application dashboard. Tax rate endpoints will not be impacted.
Posted Aug 14, 2025 - 10:40 EDT
This scheduled maintenance affected: TaxJar Reporting and TaxJar API (Tax Calculations API, Transaction Push API).