Slow Performance
Incident Report for TaxJar
Resolved
We have seen response times return to normal at this time.
Posted about 2 years ago. Oct 11, 2016 - 10:35 CDT
Monitoring
We have been alerted to some potential slower responses times and we are monitoring the servers at this time.
Posted about 2 years ago. Oct 11, 2016 - 09:32 CDT