New account creation
Incident Report for TaxJar
Resolved
This issue has been resolved by Stripe our 3rd party vendor.
Posted Jul 10, 2019 - 12:22 CDT
Identified
We are currently monitoring an issue with a vendor having a partial outage around our account creation process. Users might have trouble creating new accounts in TaxJar Reporting at this time.

Other services are all operational.
Posted Jul 10, 2019 - 12:11 CDT
This incident affected: TaxJar Reporting.