TaxJar Reporting - Dashboard Performance Issues
Incident Report for TaxJar
Resolved
This incident has been resolved.
Posted Aug 06, 2021 - 16:20 EDT
Monitoring
We've identified the issue and a fix has been implemented. We're monitoring the result.
Posted Aug 06, 2021 - 16:08 EDT
Investigating
We are currently investigating issues with TaxJar Reporting UI performance.
Posted Aug 06, 2021 - 15:40 EDT
This incident affected: TaxJar Reporting and TaxJar API (Transaction Push API).